import re
regex = re.compile(r"(ABCDE\_\S*\>|ABCDE\_)", flags=re.MULTILINE)
test_str = ("Как получить \"ABCDE_1234>\" если есть \">\" \n"
"Как получить \"ABCDE_12345>\" если есть \">\" \n"
"Проверяем на строке \"ABCDE_ABCDE_>\" =)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")