use strict;
my $str = 'Как получить "ABCDE_1234>" если есть ">"
Как получить "ABCDE_12345>" если есть ">"
Проверяем на строке "ABCDE_ABCDE_>" =)';
my $regex = qr/(ABCDE\_\S*\>|ABCDE\_)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}