re = /(ABCDE\_\S*\>|ABCDE\_)/m
str = 'Как получить "ABCDE_1234>" если есть ">"
Как получить "ABCDE_12345>" если есть ">"
Проверяем на строке "ABCDE_ABCDE_>" =)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end