const regex = /(ABCDE\_\S*\>|ABCDE\_)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ABCDE\\_\\S*\\>|ABCDE\\_)', 'gm')
const str = `Как получить "ABCDE_1234>" если есть ">"
Как получить "ABCDE_12345>" если есть ">"
Проверяем на строке "ABCDE_ABCDE_>" =)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}