$re = '/(ABCDE\_\S*\>|ABCDE\_)/m';
$str = 'Как получить "ABCDE_1234>" если есть ">"
Как получить "ABCDE_12345>" если есть ">"
Проверяем на строке "ABCDE_ABCDE_>" =)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);