package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[(0.\d+|[1-9]\d*\.\d+)\D+(0.\d+|[1-9]\d*\.\d+)\] *(.*)`)
var str = `[105.68 - 143.759] some text
[143.759 - 173.88] some texT
[173.88 - 201.839] some text
[0.88 - 201.839] some text
[173.88 - 201.839]no space
[01.88 - 201.839] some text
[0.88 - 2.01.839] some text
[0.88 - .201839] some text
[173.88 - 201.839[ some text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}