import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(0.\\d+|[1-9]\\d*\\.\\d+)\\D+(0.\\d+|[1-9]\\d*\\.\\d+)\\] *(.*)";
final String string = "[105.68 - 143.759] some text\n"
+ "[143.759 - 173.88] some texT\n"
+ "[173.88 - 201.839] some text\n"
+ "[0.88 - 201.839] some text\n"
+ "[173.88 - 201.839]no space\n"
+ "[01.88 - 201.839] some text\n"
+ "[0.88 - 2.01.839] some text\n"
+ "[0.88 - .201839] some text\n"
+ "[173.88 - 201.839[ some text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}