const regex = /\[(0.\d+|[1-9]\d*\.\d+)\D+(0.\d+|[1-9]\d*\.\d+)\] *(.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[(0.\\d+|[1-9]\\d*\\.\\d+)\\D+(0.\\d+|[1-9]\\d*\\.\\d+)\\] *(.*)', 'gmi')
const str = `[105.68 - 143.759] some text
[143.759 - 173.88] some texT
[173.88 - 201.839] some text
[0.88 - 201.839] some text
[173.88 - 201.839]no space
[01.88 - 201.839] some text
[0.88 - 2.01.839] some text
[0.88 - .201839] some text
[173.88 - 201.839[ some text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}