import re
regex = re.compile(r"\[(0.\d+|[1-9]\d*\.\d+)\D+(0.\d+|[1-9]\d*\.\d+)\] *(.*)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("[105.68 - 143.759] some text\n"
"[143.759 - 173.88] some texT\n"
"[173.88 - 201.839] some text\n"
"[0.88 - 201.839] some text\n"
"[173.88 - 201.839]no space\n"
"[01.88 - 201.839] some text\n"
"[0.88 - 2.01.839] some text\n"
"[0.88 - .201839] some text\n"
"[173.88 - 201.839[ some text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")