import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*sources\\s*: \\[\\s*\"(.*?)\"";
final String string = "<script type='text/javascript'>var player = new Clappr.Player({\n"
+ " sources: [\"https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4\"], \n"
+ " preload: 'none',\n"
+ " poster: \"https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg\", \n"
+ " width: \"100%\",\n"
+ " height: \"100%\",\n"
+ " disableVideoTagContextMenu: true,\n"
+ " parentId: \"#vplayer\"\n"
+ " \n"
+ " \n"
+ " });";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}