import Foundation
let pattern = #"\s*sources\s*: \[\s*"(.*?)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
<script type='text/javascript'>var player = new Clappr.Player({
sources: ["https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4"],
preload: 'none',
poster: "https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg",
width: "100%",
height: "100%",
disableVideoTagContextMenu: true,
parentId: "#vplayer"
});
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)