import re
regex = re.compile(r"\s*sources\s*: \[\s*\"(.*?)\"", flags=re.MULTILINE)
test_str = ("<script type='text/javascript'>var player = new Clappr.Player({\n"
" sources: [\"https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4\"], \n"
" preload: 'none',\n"
" poster: \"https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg\", \n"
" width: \"100%\",\n"
" height: \"100%\",\n"
" disableVideoTagContextMenu: true,\n"
" parentId: \"#vplayer\"\n"
" \n"
" \n"
" });")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")