re = /\s*sources\s*: \[\s*"(.*?)"/m
str = '<script type=\'text/javascript\'>var player = new Clappr.Player({
sources: ["https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4"],
preload: \'none\',
poster: "https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg",
width: "100%",
height: "100%",
disableVideoTagContextMenu: true,
parentId: "#vplayer"
});'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end