# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w*)(?:\w{4,}$)/SSSS/g;t' <<< "TESTTESTTESTT"