package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w*)(?:\w{4,}$)`)
var str = `TESTTESTTESTT`
var substitution = "SSSS"
fmt.Println(re.ReplaceAllString(str, substitution))
}