import re
regex = re.compile(r"(\w*)(?:\w{4,}$)")
test_str = "TESTTESTTESTT"
subst = "SSSS"
result = regex.sub(subst, test_str)
if result:
print(result)