$re = '`(\w*)(?:\w{4,}$)`';
$str = 'TESTTESTTESTT';
$subst = "SSSS";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;