const regex = new RegExp('(\\w*)(?:\\w{4,}$)', 'g')
const str = `TESTTESTTESTT`;
const subst = `SSSS`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);