use strict;
my $str = 'TESTTESTTESTT';
my $regex = qr`(\w*)(?:\w{4,}$)`p;
my $subst = 'SSSS';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";