using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\b\w)(\s)(?=\w\b)";
string substitution = @"";
string input = @"j j winston a b williams
hb d party supplies e g
t t ice cream z z specialists";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}