$re = '/(?<=\b\w)(\s)(?=\w\b)/m';
$str = 'j j winston a b williams
hb d party supplies e g
t t ice cream z z specialists';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;