re = /(?<=\b\w)(\s)(?=\w\b)/m
str = 'j j winston a b williams
hb d party supplies e g
t t ice cream z z specialists'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result