import re
regex = re.compile(r"(?<=\b\w)(\s)(?=\w\b)", flags=re.MULTILINE)
test_str = ("j j winston a b williams\n"
"hb d party supplies e g\n"
"t t ice cream z z specialists")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)