import Foundation
let pattern = #"(?<=\b\w)(\s)(?=\w\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
j j winston a b williams
hb d party supplies e g
t t ice cream z z specialists
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)