const regex = new RegExp('(?<=\\b\\w)(\\s)(?=\\w\\b)', 'gm')
const str = `j j winston a b williams
hb d party supplies e g
t t ice cream z z specialists`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);