# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^CAP0*|0$//gm;t' <<< "CAP07560
CAP41060
CAP43500
CAP22390"