using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^CAP0*|0$";
string substitution = @"";
string input = @"CAP07560
CAP41060
CAP43500
CAP22390";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}