package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^CAP0*|0$`)
var str = `CAP07560
CAP41060
CAP43500
CAP22390`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}