const regex = new RegExp('^CAP0*|0$', 'gm')
const str = `CAP07560
CAP41060
CAP43500
CAP22390`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);