re = /^CAP0*|0$/m
str = 'CAP07560
CAP41060
CAP43500
CAP22390'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result