import re
regex = re.compile(r"^CAP0*|0$", flags=re.MULTILINE)
test_str = ("CAP07560\n"
"CAP41060\n"
"CAP43500\n"
"CAP22390")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)