# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(ABC\+::[A-Z0-9]+\n)(?=^CDE\+:[A-Z0-9]+)/\1TIM+++2020:11:21:12:51+ZZZ\nABC++ADDEDTIME\n/gm;t' <<< "ABC+::A1
CDE+:A1A1A1"