using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(ABC\+::[A-Z0-9]+\n)(?=^CDE\+:[A-Z0-9]+)";
string substitution = @"\1TIM+++2020:11:21:12:51+ZZZ\nABC++ADDEDTIME\n";
string input = @"ABC+::A1
CDE+:A1A1A1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}