# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(ABC\+::[A-Z0-9]+\n)(?=^CDE\+:[A-Z0-9]+)"
test_str = ("ABC+::A1\n"
"CDE+:A1A1A1")
subst = "\\1TIM+++2020:11:21:12:51+ZZZ\\nABC++ADDEDTIME\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.