import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(ABC\\+::[A-Z0-9]+\\n)(?=^CDE\\+:[A-Z0-9]+)";
final String string = "ABC+::A1\n"
+ "CDE+:A1A1A1";
final String subst = "\\1TIM+++2020:11:21:12:51+ZZZ\\nABC++ADDEDTIME\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}