const regex = new RegExp('^(ABC\\+::[A-Z0-9]+\\n)(?=^CDE\\+:[A-Z0-9]+)', 'gm')
const str = `ABC+::A1
CDE+:A1A1A1`;
const subst = `\1TIM+++2020:11:21:12:51+ZZZ\nABC++ADDEDTIME\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);