import Foundation
let pattern = #"^(ABC\+::[A-Z0-9]+\n)(?=^CDE\+:[A-Z0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABC+::A1
CDE+:A1A1A1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1TIM+++2020:11:21:12:51+ZZZ\nABC++ADDEDTIME\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)