use strict;
my $str = 'ABC+::A1
CDE+:A1A1A1';
my $regex = qr/^(ABC\+::[A-Z0-9]+\n)(?=^CDE\+:[A-Z0-9]+)/mp;
my $subst = '\\1TIM+++2020:11:21:12:51+ZZZ\\nABC++ADDEDTIME\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";