#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\$Log:.*[\r\n]*.*[\r\n])(.*)"
Local $sString = "/*" & @CRLF & _
"******************************************************************" & @CRLF & _
"$Log: oldfile.c,v $" & @CRLF & _
"Revision 11.4 2000/01/20 19:01:41 userid" & @CRLF & _
"blah blah blah" & @CRLF & _
"" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")