package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\$Log:.*[\r\n]*.*[\r\n])(.*)`)
var str = `/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}