using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\$Log:.*[\r\n]*.*[\r\n])(.*)";
string input = @"/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}