import Foundation
let pattern = #"(\$Log:.*[\r\n]*.*[\r\n])(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/*
******************************************************************
$Log: oldfile.c,v $
Revision 11.4 2000/01/20 19:01:41 userid
blah blah blah
*/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)