# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^?]+)(?:\??)(?!(?:.*)&?show_pinned_search=1(?:&.*)?$)(.*)$/$1?show_pinned_search=1&$2/g;t' <<< "https://www.example.com/property/villa-alexia/BC?zz=3&zz=8&show_pinned_search=1&"