import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^?]+)(?:\\??)(?!(?:.*)&?show_pinned_search=1(?:&.*)?$)(.*)$";
final String string = "https://www.example.com/property/villa-alexia/BC?zz=3&zz=8&show_pinned_search=1&";
final String subst = "$1?show_pinned_search=1&$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}