using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^?]+)(?:\??)(?!(?:.*)&?show_pinned_search=1(?:&.*)?$)(.*)$";
string substitution = @"$1?show_pinned_search=1&$2";
string input = @"https://www.example.com/property/villa-alexia/BC?zz=3&zz=8&show_pinned_search=1&";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}