import Foundation
let pattern = #"^([^?]+)(?:\??)(?!(?:.*)&?show_pinned_search=1(?:&.*)?$)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"https://www.example.com/property/villa-alexia/BC?zz=3&zz=8&show_pinned_search=1&"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1?show_pinned_search=1&$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)