#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([^?]+)(?:\??)(?!(?:.*)&?show_pinned_search=1(?:&.*)?$)(.*)$"
Local $sString = "https://www.example.com/property/villa-alexia/BC?zz=3&zz=8&show_pinned_search=1&"
Local $sSubst = "$1?show_pinned_search=1&$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)