$re = '%^([^?]+)(?:\??)(?!(?:.*)&?show_pinned_search=1(?:&.*)?$)(.*)$%';
$str = 'https://www.example.com/property/villa-alexia/BC?zz=3&zz=8&show_pinned_search=1&';
$subst = "$1?show_pinned_search=1&$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;