const regex = new RegExp('^([^?]+)(?:\\??)(?!(?:.*)&?show_pinned_search=1(?:&.*)?$)(.*)$', 'g')
const str = `https://www.example.com/property/villa-alexia/BC?zz=3&zz=8&show_pinned_search=1&`;
const subst = `$1?show_pinned_search=1&$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);