#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(('|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\").*?(\n^.*?){0,4}(('|\")[a-zA-Z0-9+/]{40}('|\"))+|('|\")[a-zA-Z0-9+/]{40}('|\").*?(\n^.*?){0,3}('|\")((?:ASIA|AKIA|AROA|AIDA)([A-Z0-7]{16}))('|\"))+"
Local $sString = "import json" & @CRLF & _
"" & @CRLF & _
"from amazon_pay.client import AmazonPayClient" & @CRLF & _
"" & @CRLF & _
"#client = AmazonPayClient(" & @CRLF & _
"# mws_access_key='AKIAJIUGYOGHT2ONMCOQ'," & @CRLF & _
"# mws_secret_key='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'," & @CRLF & _
"# merchant_id='A2GWANJA6L1J87'," & @CRLF & _
"# region='na'," & @CRLF & _
"# currency_code='USD'," & @CRLF & _
"# sandbox=True)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")